HEADER FAILED TO MATCH and Gateway Internal Error (sometimes)
  1. Vu Ngo
  2. General
  3. Monday, 13 August 2018
Hi,
I'm trying to implement eNETS web browser integration (Flow 1) on our test server. When I submit the transaction, either one of the two scenarios will happen:
- Scenario 1:
   + The screen to choose payment method will appear (as seen in this image)
   + If I choose anything but the lower DBS logo, I will get redirected to the real ibanking page with the banks for login, which I suppose is the correct behaviour. However I'm unable to use that for testing
   + If I choose the DBS logo in the red square, I will get redirected to the Bank simulation page, which I can then choose to fire a successful transaction response (as seen here)
   The problem is that even if I choose to fire a successful transaction, I will get redirected to the B2S end URL and encounter a HEADER FAILED TO MATCH error with the transaction request details (this is an example). Below are some additional examples for your reference:
HEADER FAILED TO MATCH. Header received :mGDiGKE+/CkTtoPSXDGJ5C5yP7ua58tWvASp4TeN510=headerGenrated : 7Wl2XkkQNNjLPOkz8up1BHpZqEdgHWJ4W64Wdc/AYbU=-------------Decoded Message :{"ss":"1","msg":{"netsMid":"UMID_877772003","tid":"127.0.0.1","submissionMode":"B","merchantTxnRef":"20180813100202110","merchantTxnDtm":"20180813 10:02:02.686","paymentType":"SALE","currencyCode":"SGD","netsTxnRef":"20180813100109028","netsTxnDtm":"20180813 10:01:11.000","paymentMode":"DD","merchantTimeZone":"+8:00","netsTxnStatus":"0","netsTxnMsg":"Transaction Successful","netsAmountDeducted":"445100","netsValueDate":"13/08/2018","bankId":"8181","bankRefCode":"20180813100218831","stageRespCode":"0006-00000","txnRand":"20180813100109028","actionCode":"0","netsMidIndicator":"U"}}
HEADER FAILED TO MATCH. Header received :kJQ7gCT6CWASuOu4ddQSzZOlvxB+6FwioXF+URi3U9Y=headerGenrated : aulOOy9qqTqC85lMEw1hta/lLPAjCDpW1VMHDjWBwUU=-------------Decoded Message :{"ss":"1","msg":{"netsMid":"UMID_877772003","tid":"127.0.0.1","submissionMode":"B","merchantTxnRef":"20180813100415566","merchantTxnDtm":"20180813 10:04:15.089","paymentType":"SALE","currencyCode":"SGD","netsTxnRef":"20180813100329029","netsTxnDtm":"20180813 10:03:31.000","paymentMode":"DD","merchantTimeZone":"+8:00","netsTxnStatus":"0","netsTxnMsg":"Transaction Successful","netsAmountDeducted":"666300","netsValueDate":"13/08/2018","bankId":"2222","bankRefCode":"20180813100400738","stageRespCode":"0006-00000","txnRand":"20180813100329029","actionCode":"0","netsMidIndicator":"U"}}
 
- Scenario 2:
   + Nothing will appear on my merchant page for around one minute (as seen here) and then I will get redirected to the B2D end URL with a HEADER FAILED TO MATCH error, with a different message (Gateway Internal Error) as shown here.
Below is the response text and transaction request details for your reference:
HEADER FAILED TO MATCH. Header received :TfVEO/kQ9pfoEg0JKkXhwcEQ9VGISEa9qhLHTQ91fg4=headerGenrated : xUnqAZybw7p67UasKxbQjEwR09SJoFg8MsPnJ1KyVy8=-------------Decoded Message :{"ss":"1","msg":{"netsMid":"UMID_877772003","merchantTxnRef":"20180813100951741","paymentMode":"DD","netsTxnStatus":"1","netsTxnMsg":"Gateway Internal Error","stageRespCode":"0042-50180","txnRand":"20180813100906038","actionCode":"1"}}
{"ss":"1","msg":{"txnAmount":"100000","merchantTxnRef":"20180813100951741","netsMid":"UMID_877772003","merchantTxnDtm":"20180813 10:09:51.799","netsMidIndicator":"U","paymentType":"SALE","merchantTimeZone":"+8:00","currencyCode":"SGD","submissionMode":"B","paymentMode":"DD","BankId":null,"b2sTxnEndURL":"https://sit2.enets.sg/MerchantApp/sim/b2sTxnEndURL.jsp","s2sTxnEndURL":"https://sit2.enets.sg/MerchantApp/rest/s2sTxnEnd","b2sTxnEndURLParam":null,"s2sTxnEndURLParam":null,"clientType":"W","MobileOs":null,"tid":"","language":"en","IpAddress":null,"Param1":null,"Param2":null,"Param3":null,"Param4":null,"Param5":null,"SupMsg":null}}
 
Scenario 1 appears a bit more often than Scenario 2 (the ratio is around 60% versus 40%). May I know what's the possible causes of this error? I can telnet to 118.201.98.241 9065 
 
Comment
There are no comments currently.
Vu Ngo Accepted Answer Pending Moderation
0
Votes
Undo

I just realized that the hyperlinks don't work. This is the link to the screenshots mentioned in the post: https://imgur.com/a/4ofEUZh 

Comment
There are no comments currently.
  1. more than a month ago
  2. General
  3. # 1
Matteo Andres Accepted Answer Pending Moderation
0
Votes
Undo

Well, I did not get the content in this post. It also looks like a post from australianwritings.com.au plagiarism. I'll need the help of my IT friend to understand the material in this page.

Comment
There are no comments currently.
  1. one week ago
  2. General
  3. # 2
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.